تبلیغات
تبلیغات

حل خطای یک کوپن باید با یک محصول فروشنده محدود شود وردپرس

در ووکامرس وردپرس، ممکن است به هنگام استفاده از کوپن یا کد تخفبف، با پیام «یک کوپن باید با یک محصول فروشنده محدود شود» مواجه شوید! علت این است که شما از افزونه‌های دکان استفاده می‌کنید. در ادامه به روش حل این مشکل می‌پردازیم.

مراحل کار

  1. وارد هاست خود شوید.
  2. از قسمت پلاگین‌ها، وارد پوشه‌ی dokan-lite و سپس پوشه‌ی includes شوید. یعنی مسیر زیر در هاست خود:
  3. به دنبال فایل class-order-manager.php بگردید و اگر چنین فایلی در این مسیر نیافتید، وارد پوشه‌ی Order شده و فایل Hooks.php را در حالت ویرایش باز کنید.
  4. به دنبال خطی که عبارت «woocommerce_coupon_is_valid» در آن وجود دارد بگردید؛ که می‌تواند خط زیر باشد:
  5. این خط را حذف کرده و یا پشت آن، علامت # یا // قرار دهید تا از کار بیفتد.
کانال تلگرام فول کده
تبلیغات

درباره نویسنده

هادی اکبرزاده

[ مدیر فول کده ]

علاقه‌مند به اشتراک‌گذاری اطلاعات در هر زمینه‌ای
برنامه‌نویس فول استک

پاسخ دهید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

نظرات ثبت شده بدون دیدگاه